Squeaky M55 (ive read old posts, problem not solved)

https://www.youtube.com/watch?v=7d3GxQVj1Kg

Video explains the issue, but pretty much my m55 has been squeaky. I've oiled up the pivot points and the eye, still can't figure out whats going on. Any help would be greatly appreciated!

Some points you may not have tried (or maybe you have)

1) Loosen up the spring for the damper tension all the way. See if you can turn in 1/4 turn, put a drop of oil on the top and bottom of the spring, better yet remove and put some Vaseline on the top and bottom of the spring.

2) Put a drop of oil on every point on the petal assembly. Sounds can seem like they sound in one place and come from another.

3) Gently push the resonators apart see if that changes.

4) Tighten the screws that hold the metal plate that the damper spring sits

5) Have someone push or pull each rail and pull each side of the frame as you are pushing the pedal. On especially older vibes, the wood can move and cause squeaks.

6) Put a little Vaseline on the rod where it connects to the round bolt on the damper.

Sounds like there is friction in the damper pedal rod hook. Wrap teflon tape around the hook.

Barry

I'm with Barry. Everyone with a Musser instrument should keep a $.79 roll of teflon tape with them at all times. Worth its weight in platinum.

Oh yeah, I forgot to mention I had a squeak that was caused by some new post insulators. Pretty easy to diagnose, just remove the bars and see if it goes away.

I finally changed to silicon tubing that I cut myself and it solved the problem.

IG